Using the Editor (How-to)

The default editor used in TerminalFour is TinyMCE. You use this editor to enter or edit text and insert items from the media library. The functionality of TinyMCE is similar to other common word processing tools. As you create text, a shadow version in HTML (the code that runs the website) is created on the back end. This ensures that your text and links look like the rest of the Drake website.

NOTE: Be sure to do all your formatting inside of T4. If you cut and paste from Word or other software it will cause major formatting issues.


1. Toolbar Layout

The buttons on the toolbar are similar to other word processing tools.

Toolbar and content area screenshot

Familiarize yourself with the functions and descriptions of the individual toolbar icons below.

Icon Name Description
Undo button Undo To undo the last change made.
Redo button Redo To redo the last change which was undone.
Bold button Bold Changes the text to bold.
Italics button Italics Changes the text to Italics.
Align Left button Align left Justifies the text left.
Align Center button Align center Justifies the text centered.
Align Right button Align right Justifies the text right.
Unordered List button Unordered list Inserts a bulleted list. (Use for items of no particular rank.)
Ordered List button Ordered list Inserts a numbered list. (Use for steps, or items with a specific rank.)
Negative Indent button Negative indent Decreases any indent applied to a paragraph.
Indent button Indent Indents a paragraph, or highlighted block, of text.
Link button Insert/edit link Inserts a link: section, content, external or anchor.
Remove link button Remove link Removes a link.
Insert Media button Insert Media Inserts media from the Media Library.
Spell check button Spell Check Executes a spell check
Remove Formatting button Remove Formatting Removes all formatting, and removes media items. Click Undo to restore formatting.

2. Drop Down Menus

Some functions are repeated in the drop down menus, while others can only be found in them. For each of the menus below, only the features not explained above will be discussed.

Edit Menu

  1. Cut any selected content.
  2. Copy any selected content.
  3. Paste content currently stored in your clipboard.
  4. If switched on, this will paste content from your clipboard into the content area as plain text. NOTE: Be sure to do all your formatting inside of T4. If you cut and paste from Word or other software it will cause major formatting issues.
  5. Select all content - usually used in conjunction with Copy or Paste.
  6. Find and replace text.

Edit Menu explained screenshot

Insert Menu

  1. Adds a Horizontal line to content. NOTE: Link functions are explained in the Using Links (How-to) knowledge base article. 

Insert Menu screenshot

View Menu

  1. Gives you the ability to turn on/off the Visual aids for borderless tables.
  2. Displays the content area in Fullscreen mode.

View menu screenshot

Format Menu

  1. Places an Underline below the text. Not recommended as people assume underlined content is a link.
  2. Places a line though the text. Also not recommended.
  3. Changes text to Superscript or Subscript. Useful for scientific notations or footnotes.
  4. Drops down into a sub menu of text Formats. There's a breakdown of this below.
  5. Clear formatting from highlighted text.

Format menu screenshot

Formats Menu Breakdown

  1. The heading options go from largest and most important (Heading 1) down to the smallest heading (Heading 6). The size, boldness, and color of these is determined across the entire Drake website. This setting will be applied to whatever text is highlighted.
  2. This formats the highlighted text to the larger intro text that is typically used at the top of a section (page). The size and type choice are determined across the entire website.

Formats menu drilldown screenshot

Table Menu

  1. Once you Insert table, the other options will be available. You can edit cells, rows, and columns. The table's look and feel is consistent across the entire website.

Table Menu screenshot

Tools Menu

  1. The Spellcheck option places a red line beneath all of the misspelled words. To correct a word, click the pointer on the word. An on-screen pop up window will show you possible correct spellings.
  2. View the HTML Source code of your content via a pop-up window.

Tools menu screenshot